WHMCS Security Threat 5.2.12 Cookies Vuln

Setelah membaca security hole yang di beberkan oleh member Webhostingtalk di http://www.webhostingtalk.com/showthread.php?s=bee961a8290f064dff48ba090c252518&t=1318742

 

Kemudian membaca di blog WHmcs.Com sbb :

http://blog.whmcs.com/?t=81138

 

Di sarankan pengguna WHMCS versi terbaru pun di haruskan update patch ini untuk melindungi cookies vuln yg terdapat pada whmcs :

 

We are aware of a post that is circulating in which the author proposes an exploit via a cookie variable. However the proposed vulnerability is only possible if the attacker has gained access to a valid admin login session already through other means. For this reason, we feel that the viability of the vulnerability is not immediate nor is of a critical risk to installations.

We can confirm this vulnerability vector does exist as we have already identified and resolved it in our currently in progress internal security audit. We have in fact also prepared a refinement to the code that will negate the proposed attack vector and we anticipate publishing a new release of the software next week that will include this change along with others found during our internal audit.

In the meantime however, you may download the hook file below and upload it to the /includes/hooks/ folder of your WHMCS installation to negate any potential attacks based on this – although please note this will also prevent admin list ordering from working fully in certain places.

Cookie Override Hook – http://go.whmcs.com/262/cookie_override_hook

Staff Admin

BIla anda membutuhkan : - Hosting - Domain - VPS - dsb Silahkan menuju web utama kami : https://atriumhosting.com atau : SMS/WA : 081237908888 PIN BBM : 537DD283 Yahoo Messenger : onlineonline09